iPad 2

JailbreakMe-3.0-Leaked

How JailbreakMe 3.0 Was Leaked

Yesterday was a sad day for everyone in the Jailbreak community. Someone by the name “MultiMediaWill” intentionally leaked the iPad 2 PDF Jailbreak (for iOS 4.3 only) to the public. But surprisingly, it wasn’t all MultiMediaWill’s fault – and, he wouldn’t even have the file if it weren’t for Ryan Lobbins….

iPad 2 Jailbreak (JailbreakMe 3.0) Leaked

Yeah, you read that correctly, the source code for JailbreakMe 3.0 was leaked – as of now, it only works for iPad 2 users on iOS 4.3. Keep in mind that this is a buggy version of the Jailbreak and once Comex found out about it, he had this to…

It's-Been-Far-Too-Long-JailbreakMe

JailbreakMe.com: Strange Things Are Going On

Late last night Comex updated JailbreakMe.com to show his history of commits to github – according to veeence and p0sixninja, he probably did this to show that he’s been working on it since August 31th 2010: I’ve also noticed that sometimes JailbreakMe.com will display Star (JailbreakMe 3.0) and other times…

JailbreakMe-3.0-iPhone.jpg

JailbreakMe 3.0 Will Be Released Shortly

As I mentioned on twitter early this morning, it’s probably a good idea to backup your iOS 4.3.3 SHSH blobs because once Comex releases JailbreakMe 3.0, Apple will most likely patch it with a small firmware update. But the good part is that Comex just tweeted practically the same thing…

JailbreakMe 3.0 Is Almost Ready!

There’s not much to say other than this: JAILBREAKME 3.0 is ALMOST COMPLETE – now would be the appropriate time to jump for joy! According to Comex (the developer of JailbreakMe 3.0), he just has to finish up some last minute things and then it’ll be released. Veeence also pointed…

Cydia-SHSH-Blobs

Apple Will Prevent Downgrading With SHSH Blobs After iOS 5

According to MuscleNerd (a reliable Jailbreaker), the days of downgrading newer devices (ones that require SHSH blobs) are coming to an end! According to him, you will no longer be able to use SHSH blobs to downgrade after iOS 5 – but if you have an older version of iTunes…